I recently ran into a problem with Gimp (for the second time now) that I had encountered before so I thought I would post the fix - even though the fix is out there on the net somewhere since I used someone else's advice before!  ;-)

It is my understanding that this can happen with other files with the GTK but I haven't run into them yet.  I haven't found out the origin of the conflict yet because GIMP worked when I installed it but I cannot remember all of the applications I have installed since then.  Oh well.


XMLParse.dll Error
When opening GIMP I got the folllowing error:
gimp-2.0.exe - Entry Point Not Found
The procedure entry point XML_SetDoctypeDeclHandler could not be located in the dynamic link library xmlparse.dll
This is the screenshot of the xlmparse.dll error message detailed above

The problem file was the xmlparse.dll file in c:\windows\system32.  I renamed that file to xmlparse.dll.old and copied in xmlparse.dll from C:\Program Files\Common Files\GTK\2.0\bin.  (this was after doing a search on the system to find the relavant file - it may be in a different location on your system.


XMLtok.dll Error

I tried reopening GIMP and immediately got another error message:
gimp-2.0.exe - Entry Point Not Found
The procedure entry point XmlInitUnknownEncodingNS could not be located in the dynamic link library xmltok.dll.
This is the screenshot of the xlmtok.dll error message detailed above

The fix was identical to what I did with the xmlpase.dll file only this time with the xmltok.dll file.

Erik Smith 2005
Licensed under the GNU Free Documentation License